x


My scene is empty

Hello, I've just started with unity. I like it very much but I have one problem I cant see anything in the scene. If I create for example a terrain I can see it in the game window but not in the scene.A screen :http://www.mijnbestand.nl/Bestand-PNOATLNYGS3M.png On the screen I did focus on the terrain with the F key. My rig: Processor:
Intel(R) Core(TM)2 Quad CPU Q8200 @ 2.33GHz (4 CPUs), ~2.3GHz Memory:
4096MB RAM Hard Drive:
737 GB Video Card:
NVIDIA GeForce 9800 GTX+
Operating System:
Windows 7 Ultimate

I hope someone can help me.

more ▼

asked Mar 02 '11 at 09:43 AM

PocKeT gravatar image

PocKeT
16 2 2 4

Yes, I too am also having this issue and I'm getting tired of people posting responses like "hit F" when it is stated in the question that they have already done so.

Here is the best I can explain about the problem:

Game objects are selectable only through Hierarchy tab. Objects that are shapes (i.e. sphere, cube) have a blue outline but no shader. Other Game Objects (lights, camera, GUI text) are simply not visible at all, whether selected and focused on or not. Objects are also visible in the Game tab but CAN NOT BE SELECTED IN THE SCENE TAB!!!!

Here is a screengrab of the issue. Scene View non-selectable

I am new to Unity and haven't messed with preferences or anything and I can't seem to find out how to solve this issue. Please help!

Apr 27 '11 at 01:43 AM Crow Pickle

im having the same issue, any solution yet?

May 10 '11 at 01:23 PM Graeme P

I am also having the same problem. I hope it will be solved. The first time I've tried Unity it was Ok but I dont know what happened when I used Unity again, It all went the same as what you have mentioned. But If I use the Bootcamp project the scene options(Textured,Wireframe) is well functioning.

Jul 15 '11 at 08:16 AM coercive_power

Solved :)) Thanks

Jul 15 '11 at 08:50 AM coercive_power

Layers. Top-right.

Search box. Also top-right.

Comment button. Bottom-right.

Jul 15 '11 at 08:32 AM Waz

"Game objects are selectable only through Hierarchy tab. Objects that are shapes (i.e. sphere, cube) have a blue outline but no shader. Other Game Objects (lights, camera, GUI text) are simply not visible at all, whether selected and focused on or not. " --that's my problem... can u provide a step by step instructions..please :(

Jul 15 '11 at 08:42 AM coercive_power
(comments are locked)
10|3000 characters needed characters left

6 answers: sort voted first

Click on the terrain in the hierarchy and press 'F'. This will focus and zoom on the terrain in your scene window. Make sure you turn you view a little, or you might end up being precisely on the side of your terrain, and if it's flat, you still won't see it! :)

But try different orientations as well.

more ▼

answered Mar 02 '11 at 09:53 AM

taoa gravatar image

taoa
1.6k 8 13 35

It doesent work I can see the little arrows to move the terrain but thats all.

Mar 02 '11 at 10:04 AM PocKeT

Try it with a simpler, smaller and solid object that can be seen from all directions lie a cube or a sphere. Make sure you didn't changed the scene view rendersettings at the to of the scene view. Should be Textured and RGB. Turn the lighting (next button) off. If you create a new cube: GameObject--> Create other --> Cube, then you select the cube in your hierarchy and move your mose over the sceneview and press "F". If you really can't see anything, maybe edit your question and add some information about your computer, unity version... In the end you could file a bugreport.

Mar 02 '11 at 10:24 AM Bunny83

no it dident work :(

Mar 02 '11 at 07:14 PM PocKeT

Check the top-right Layers is everything.

Jul 15 '11 at 08:31 AM Waz
(comments are locked)
10|3000 characters needed characters left

There is a Layer Icon in top left, Make sure "Default" is enabled. I'ts worked for me.

more ▼

answered Jan 20 '12 at 03:24 AM

Sebaaz666 gravatar image

Sebaaz666
31 1 1 2

yes this works for me too.

thank you

Apr 13 '12 at 10:55 AM mvx
(comments are locked)
10|3000 characters needed characters left

Hey guys,

New user here and I know this is an old thread but I found it searching and maybe the next person who does will benefit:

I was having the same problem as described in this and other threads: an all gray viewport, no grid, geometry invisible in scene unless selected in the hierarchy. Position and scale were 0,0,0 and 1,1,1 and applying a texture or creating a light made no difference.

There were two problems, both simple but frustrating for a noob like me regardless:

1) missing grid: It turns out there IS a grid toggle; it's the background button between the light toggle and the sound toggle, just above the viewport. Unity could really use a "view" drop down so these options are in locations similar to Max and Maya, even if redundant. Mouseover tags would be nice too.

2)Objects not displaying: despite switching numerous scenes and projects and re-installing Unity twice, my UI settings didn't reset and some layers stayed turned off (presumably from my messing with them in the tutorials), including the default later! You can create objects on the default layer while it's turned off, thus making your objects invsible in scene view but visible in the game view.

Short answer: make sure you don't have anything on hidden layers!

Feature request: It'd be fantastic if "revert factory settings" would also revert to default visibility settings, including layers and within viewports!

more ▼

answered Jun 26 '11 at 09:57 PM

switchblade327 gravatar image

switchblade327
1 1

switchblade327 thank you!!! You have no idea how funstrating this has been.

Dec 20 '11 at 11:24 PM BGPROCKS

Well, I had the exact same problem before I found the solution so I do have some idea :)

Dec 21 '11 at 04:53 AM switchblade327
(comments are locked)
10|3000 characters needed characters left

do you guys have a camera in your scene if yes then make sure some thing is displayed in camera preview if not then go to gameobjects->create other->camera and adjust it accordingly let me know if it solves the problem

more ▼

answered Feb 08 '12 at 02:02 PM

arslanmkhan gravatar image

arslanmkhan
1 1 2

(comments are locked)
10|3000 characters needed characters left

hello everybody none of the methods work for me please help

more ▼

answered Apr 11 '13 at 03:57 PM

unity3D_master gravatar image

unity3D_master
1

(comments are locked)
10|3000 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Topics:

x2103
x1027
x64

asked: Mar 02 '11 at 09:43 AM

Seen: 8254 times

Last Updated: Mar 05 at 01:29 AM