x


How do you stop objects from floating into space?

Hello,

I am a beginner at Unity and started to make my first 3D project with it. It's an FPS game so I placed a First-Person controller in the world but when I ran the program, everything I place in the world(except the terrain) floats slowly upward into space. Any help would be very appreciated!

Thanks.

more ▼

asked Feb 17 '13 at 04:10 AM

SkilledAssassin6 gravatar image

SkilledAssassin6
0 3 3 5

Does everything I place in the world have a rigidbody? If so, set rigidbody to use gravity or is kinematic.

Feb 17 '13 at 05:09 AM alucardj
(comments are locked)
10|3000 characters needed characters left

3 answers: sort voted first

The problem is usually caused because there is a rigidbody on the terrain and while it looks like everything thing is floating it's actually the terrain falling. Due to lack of other reference points it looks like everything is floating away. Fix it by removing the rigidbody.

more ▼

answered Feb 17 '13 at 09:45 AM

NAKAS gravatar image

NAKAS
20 2 3 4

Yes I'm pretty sure your right. The terrain is falling, but I don't know how to remove the rigidbody.

Feb 17 '13 at 10:43 PM SkilledAssassin6

You might want to work through more official Unity tutorials, then. That's a basic thing. You click the object then remove the Rigidbody component using its right-click menu in the Inspector.

Feb 17 '13 at 11:15 PM Loius

I'm sorry but I don't see any "RigidBody" component.

Feb 17 '13 at 11:37 PM SkilledAssassin6
(comments are locked)
10|3000 characters needed characters left

Make sure that your character controller has a rigid body and that the character (viewed in the editor view) isn't below or partially in the ground. Make sure they are at least above ground. Also like just said, check the use gravity menu option on the character controller.

more ▼

answered Feb 17 '13 at 06:58 AM

digiben gravatar image

digiben
129 1 2

Yes that's all working fine. It's just that the terrain is falling.

Feb 17 '13 at 10:44 PM SkilledAssassin6
(comments are locked)
10|3000 characters needed characters left

The "Rigidbody" component will be on the right hand side of your screen in the Inspector when you select that object. If their is no Rigidbody it would not be falling.

If you want the ground to float you should disable gravity and make your rigid body kinematic (both settings within the Rigidbody).

more ▼

answered Feb 17 '13 at 11:46 PM

RyanZimmerman87 gravatar image

RyanZimmerman87
2k 17 24 31

Yes I know that, I'm not stupid. But still. the terrain keeps falling

Feb 17 '13 at 11:50 PM SkilledAssassin6
(comments are locked)
10|3000 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Topics:

x2104
x431

asked: Feb 17 '13 at 04:10 AM

Seen: 832 times

Last Updated: Feb 17 '13 at 11:50 PM