x


Unity on latest stable Debian 6

Hi,

I tried to run Unity on a latest stable Debian without success. I get ./main: /usr/lib32/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by ./main)

Whats wrong?

more ▼

asked Jan 01, 2013 at 10:36 AM

Christian Schmid gravatar image

Christian Schmid
41 13 10 16

Getting the same issue on a few ubuntu variants. All 64 bit installs so far.

Jan 01, 2013 at 04:36 PM MarkFinn

Here too. Debian 64 bit. Not working. Even ia32 libs are installed.

Jan 01, 2013 at 05:34 PM TRDragony

It seems Debian and derivatives (Ubuntu et al) have decreed that for reasons of "purity" the standard 32 bit runtime libraries shall not be allowed pollute their pristine 64-bit installs.

This can be circumvented/fixed/tainted (delete according to ideological preferences and viewpoints) by adding of the ia32 libraries.

 sudo apt-get install ia32-libs

on the ubuntu variants I'm stuck working with. Exact commands/package names may vary by OS versions :-(

This hasn't got me fully running on linux yet, but has certainly moved me on to a whole new set of interesting errors when I start trying to fire up networking elements.

Jan 02, 2013 at 05:18 AM MarkFinn

Doh. Just saw TRD's comment. Adding ia32 worked for me. (As answered below). Is your error the same as Christian's?

Jan 02, 2013 at 05:39 AM MarkFinn

yes, its exactly the same.

Jan 02, 2013 at 06:23 AM TRDragony
show all comments (comments are locked)
10|3000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Topics:

x6

asked: Jan 01, 2013 at 10:36 AM

Seen: 1661 times

Last Updated: Jan 02, 2013 at 12:28 PM