x


Unity 3 and MonoDevelop (keeps opening unitron)

I am trying to setup Unity 3 + MonoDevelop. I selected the MonoDevelop beta build as external script editor and synced a MonoDevelop project. If I double click on a script it Unity opens MonoDevelop, but not the project. It also always opens Unitron as well. If I double click on a line in the console it jumps to the correct line in Unitron but doesn't do so in MonoDevelop. This is quite frustrating as it seems to work on my colleagues Mac. I'm on Mac and using Unity3.0b7 (editor and monodevelop). Is there anything else I'll need to do before this works?

EDIT:
These are the log file that MonoDevelop produces when opening it from Unity: http://pastebin.com/1grDrREZ And if MonoDevelop is already open and has the correct project loaded: http://pastebin.com/1004MhFi

I don't know if that's the problem, but exceptions are never good...

more ▼

asked Sep 07, 2010 at 10:23 PM

StephanK gravatar image

StephanK
6.5k 116 106 158

(comments are locked)
10|3000 characters needed characters left

5 answers: sort voted first

There shouldn't be any other setting, and it works for me on OSX. As recent as Beta 6 someone made a reference on the beta list to similar behavior and Unity forgetting that setting. I'd recommend you record some video of the problem, including you having set it to MonoDevelop, and file a bug.

more ▼

answered Sep 10, 2010 at 07:57 AM

Ricardo gravatar image

Ricardo
5.6k 30 98 118

The setting is correct. It also DOES open MonoDevelop, just not the solution. If the solution is already open it jumps to the correct file, but not the line.

Sep 11, 2010 at 10:08 AM StephanK
(comments are locked)
10|3000 characters needed characters left

Have you tried re downloading and installing the version that comes with Unity3b7? I would try that.

After setting it to your default editor in Unity, delete all MonoDevelop related files in your project directory and run "Sync MonoDevelop Project" under the assets tab.

Hopefully rebuilding a fresh MonoDevelop peoject will fix it. Also check the MonoDevelop logs to see what happens after doing so.

more ▼

answered Sep 14, 2010 at 09:08 PM

MSylvia gravatar image

MSylvia
189 8 14 24

It already is that version. I tried deleting and syncing the project files multiple times. The MonoDevelop logs report an exception (GdkPixbuf-Critical: gdk_pixbuf_composite: assertion `dest_x >= 0 && dest_x + dest_width width' failed) but that happens everytime MonoDevelop starts up and doesn't seem to be unity specific, although it might f*** up the process somehow.

Sep 15, 2010 at 09:32 AM StephanK

Since your on a mac you could try installing AppTrap http://onnati.net/apptrap/ and then remove monodevelop. It will try and clear any files associated with MonoDevelop. Then try a reinstall.

Sep 15, 2010 at 06:25 PM MSylvia

Could you post the whole log file somewhere like http://pastebin.com/? It would be easier to diagnose seeing the whole log.

Sep 15, 2010 at 06:33 PM MSylvia

This is the log file when MonoDevelop is already open and the project is loaded: http://pastebin.com/1004MhFi Looks like there is also something wrong with the versioning module.

Sep 16, 2010 at 07:31 AM StephanK

And this is the log file after starting MonoDevelop from Unity. http://pastebin.com/1grDrREZ

Sep 16, 2010 at 07:33 AM StephanK
(comments are locked)
10|3000 characters needed characters left

What's the name of the local copy of your MonoDevelop app?

more ▼

answered Sep 13, 2010 at 07:56 AM

Tak gravatar image

Tak
257 1 3 11

You should comment followup questions to the original question - this is not an answer!

Sep 13, 2010 at 08:01 AM Marowi

Name is MonoDevelop-Unity. The version is the one from the beta7 download site.

Sep 13, 2010 at 09:03 AM StephanK

It's MonoDevelop-Unity.app with that capitalization?

Sep 13, 2010 at 09:31 AM Tak

Sorry, the app is named "MonoDevelop", the folder containing the settings was named MonoDevelop-Unity.

Sep 13, 2010 at 11:28 AM StephanK

Ok, so it's MonoDevelop.app with that capitalization?

Sep 14, 2010 at 11:37 AM Tak
(comments are locked)
10|3000 characters needed characters left

I'm experiencing similar behavior when MonoDevelop takes too long to start up (which happens not that frequently on my machine but sometimes, it does). It seems that Unity has some sort of timeout when it falls back to opening Unitron as it knows Unitron is always there (and starts quite quickly ;-) ).

Also, when MonoDevelop then finally starts, the project isn't opened.

However, when I already have MonoDevelop open when double clicking in Unity, everything works quite smoothly. So maybe that'll also do it for you?

EDIT: Hm ... while I can't reproduce your problem, I have an idea what might possibly solve it: You might have to delete the MonoDevelop-Cache. You'll find that in

/Users/<YourUserName>/.config/MonoDevelop-Unity

What I just did was open the terminal, and then

cd .config/
mv MonoDevelop-Unity MonoDevelop-UnityBackup

(you could probably do the same in the finder but I think the finder doesn't automatically display ".*"-files.)

Maybe that fixes your issue (and if not, you can easily revert).

more ▼

answered Sep 10, 2010 at 04:32 PM

jashan gravatar image

jashan
11.5k 46 82 157

IF the project is already open it does open the correct file, but it doesn't jump to the correct line. Looking at the MonoDevelop log file i can see that it throws an exception at startup. (GdkPixbuf-Critical: gdk_pixbuf_composite: assertion `dest_x >= 0 && dest_x + dest_width width' failed ) Maybe that is part of my problem? Or do you get the same?

Sep 10, 2010 at 10:05 PM StephanK

Ah, interesting. I'm getting the same exception during MonoDevelop startup. I guess that's worth filing a bug report. When MonoDevelop is not open and I double click a file, MonoDevelop opens, with the right solution but doesn't open the correct file. However, once MonoDevelop is open, double click a file works smoothly, and so does clicking a message linked to a code-file in the console.

Sep 11, 2010 at 12:34 PM jashan

Hm ... I tried to get that exception away and remembered that sometimes you need to delete the MonoDevelop cache. I've edited my answer with an explanation how that can be done. Hope that helps!?

Sep 11, 2010 at 12:40 PM jashan

I just tried deleting it. The exception is still there and the behaviour the same.

Sep 12, 2010 at 09:32 AM StephanK

I'm getting a similar problem. If I double click a script inside Unity - it opens both Unitron and Monodevelop (but only unitron opens the file itself). In monodevelop I have to search manually for the Synched project file.

Any ideas?

Dec 20, 2010 at 09:48 AM gl33mer
(comments are locked)
10|3000 characters needed characters left

I've been watching this question with some interest, as I recently started getting the same behavior.

I finally fixed it by removing all but one version of MonoDevelop from my hard-drive (I even emptied the trash.) Then I put the last copy in Applications- this worked! Then I realized what had occurred. MonoDevelop used to be a separate download, and I originally put it in my Applications folder. For the latest download it was included in the Unity folder, and I left it there without telling Unity the new location.

So make sure the latest version of MonoDevelop is where Unity expects it, wherever you browsed to it originally. Or better yet, go back to the Unity Preferences menu and point it to the new location in the Unity folder (which is where new versions are going to be from now on.)

If that doesn't fix it, you may need to remove any other versions from your hard drive and empty the trash.

more ▼

answered Sep 18, 2010 at 09:31 PM

Bampf gravatar image

Bampf
5.6k 14 42 70

(comments are locked)
10|3000 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Topics:

x754
x14

asked: Sep 07, 2010 at 10:23 PM

Seen: 5992 times

Last Updated: Sep 16, 2010 at 01:30 PM