x


How to set Visual Studio 2010 as default script editor in Unity

Hi,

I am starting to learn how to use Unity.

I am following some good tutorial videos from 3D Buzz, and they are using Visual Studio 2008. 3D Buzz

I want to follow on, so I have downloaded Visual Studio 2010 C# Express, but unlike what they do in their videos, I can't get Unity to use Visual Studio Express as the default script editor.

I am hitting Edit --> Preferences ... --> External Script Editor. But how am I supposed to select Visual Studio Express? Do I need to navigate to the file itself on my hard drive, and if so, can you please help me find it? I have searched through my folders, but there are simply too many in the Microsoft Visual Studio Express that I don't know which one to choose. Keep in mind that I am also new to Visual Studio Express as well.

Thank you in advance.

Screenshot of the windows

more ▼

asked Aug 23, 2010 at 10:06 AM

Wikzo gravatar image

Wikzo
13 1 2 6

(comments are locked)
10|3000 characters needed characters left

4 answers: sort voted first

You aren't allowed to open VS Express from within Unity (even though you can browse and select it in preferences) you'd need VS Pro or some other version of VS. The reason why intellisense might not work is because you haven't sync'd Unity to your VS project.

more ▼

answered Aug 23, 2010 at 05:15 PM

joedrigon gravatar image

joedrigon
261 16 14 22

(comments are locked)
10|3000 characters needed characters left

OK I found the solution... It's pretty simple and pretty much works just as it should, it just doesn't TELL us that its working!

Here you go: (tested with latest version of Unity 3 (downloaded it on 18th feb 2011; and VS2010 Express):

1 . Edit --> Preferences ... --> External Script Editor -> "C:Program FilesMicrosoft Visual Studio 10.0Common7IDEvcsexpress.exe"

So far so good right, everyone's doing just this... Well... its already working! you just don't know it!

2 . right-click your script file -> "Sync MonoDevelopment Project" - YES, it SAYS "MonoDevelopment", but what it really means is "Visual Studio Express"; so go for it and click it

double-clicking script files will still open mono, so here you give up... forget double clicking the files...

3 . open your project folder in windows explorer and your VISUAL STUDIO project (".csproj") and solution (".sln") files are sitting there; open the project file and visual studio will do the rest; with INTELLISENSE and everything!

Now we just don't have the ease of clicking stuff in Unity to open in VS, we have to go into VS and manipulate files ourselves; but its no biggie really... :-)

more ▼

answered Feb 20, 2011 at 02:30 PM

LFLFM gravatar image

LFLFM
66 6

Dude this is AMAZING

Jan 27, 2012 at 06:10 PM SirGive

I tried it with Unity 4.0.0, but i failed. i think i got trapped at step 3, but i dont understand exactly what it says. so i tried to create a MVC# probject into my unity folder; start the project from here; redo step 2; reinstall MVC#; redoing above atempts.

what am i missing here?

May 23, 2013 at 09:02 PM BeB_Wir3

I had it working with unity 4.1.5. After the step 2 "sync MonoDevelop Project" the .sln file exists in the project folder and can be open with visual studio express 2010 with intellisense and everything.

Jul 06, 2013 at 10:32 AM Lythom

Yeah i got it going now. I thought i could open the scripts via unity, which i hoped for, but i silmpy can't. But syncing the project and then opening VS workes for me.

Also, what an amazing program to work with, it's making me lazy.

Jul 06, 2013 at 06:00 PM BeB_Wir3
(comments are locked)
10|3000 characters needed characters left

Ok, I think I found it via "C:Program FilesMicrosoft Visual Studio 10.0Common7IDEvcsexpress.exe"

Now I have another problem, however, that when I open up a script in Visual Studio Express, the autocomplete intellisense doesn't work.

I don't know whether this is a Unity or Visual Studio related question, but in the video when he types "transform.", a box appears and shows him a bunch of options like "transform.position.x".

Does anybody know how to enable this feature? I have tried to press CTRL+ALT+SPACE (I Googled it), but it doesn't work.

more ▼

answered Aug 23, 2010 at 10:45 AM

Wikzo gravatar image

Wikzo
13 1 2 6

You shouldn't post questions in answers ... make it kind of difficult to answer properly (answering in comments is not really ideal).

If you're using the solution created by Unity, this should work immediately. Maybe you're project / solution is missing the reference UnityEngine.dll. However, I think there may be a limitation with VCsExpress that prevents you from using that solution ... in that case, it should still work when you simply open the project that Unity creates.

Aug 23, 2010 at 11:33 AM jashan
(comments are locked)
10|3000 characters needed characters left

There is now a page in the doc´s explaining how to get Unity to work with Visual Studio Pro or Express. Read up on it here.

more ▼

answered Jun 17, 2011 at 03:20 PM

Joshua gravatar image

Joshua
6.9k 47 48 104

(comments are locked)
10|3000 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Topics:

x511
x104
x35

asked: Aug 23, 2010 at 10:06 AM

Seen: 30222 times

Last Updated: Jul 06, 2013 at 06:00 PM