Before updating to Windows 10 you may need to return your Pro license. More information here

How to add texture to Blender objects properly?

I made a 3D model in Blender, saved it to my desktop as "Seven.blend" I also saved a camouflage-tile image as "Camo.jpeg"

Then I imported these files into my unity project. When I create a prefab, fill it with the "Seven" object and then attach the mesh renderer component to it. I use the "Camo" image for the material.

Here is the problem... The object does not display the image's pattern. It just shows the color green. Possibly the average color in the image, or maybe the top-left pixel?

How can I properly attach materials to objects so that it is displayed the way you would expect? I have had this problem several times. The desired effect works flawlessly when I use the material on Unity built-in objects such as the Cube, Sphere, Capsule, and Plane.

Thank you.

more ▼

asked Aug 22, 2010 at 05:41 AM

avatar image

251 63 46 56

(comments are locked)
10|3000 characters needed characters left

2 answers: sort voted first

You have to UV map models in order to texture them.

more ▼

answered Aug 22, 2010 at 07:14 AM

avatar image

121k 79 363 774

(comments are locked)
10|3000 characters needed characters left

There is Different ways to texture it for different versions, I myself have used 2.63, To texture in that one you

First:click the material button, Then turn Specular all the way down.

second:Click the Textures button then find the type option and click it then select image or movie Third:Click coordinates then choose UV.

That should work if u have 2.63

more ▼

answered Jun 10, 2012 at 03:43 AM

avatar image

0 3 2 3

(comments are locked)
10|3000 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments



asked: Aug 22, 2010 at 05:41 AM

Seen: 11026 times

Last Updated: Jun 10, 2012 at 03:43 AM