x


(Blender and Unity) linking an armature to an object break it

Hello, I'm a beginner in Unity, in Blender and, in fact, in 3D modelling in general.

I made a scorpion in Blender for my game and it's well imported in Unity but every time I try to give it an armature in Blender, for animate it, it looks good on blender but not at all in Unity.

It seems that the normals of the bones are used instead of the object's ones. I read this happen when we give two armatures to a single model or when we made an armature with one bone only. But it's not my case.

Here's my scorpion with armature in Blender:

http://imgur.com/a/G9LcG#0

And here in Unity:

http://imgur.com/a/G9LcG#1

=> The one on the right hasn't any armature. The left one is the scorpion of the Blender's screen who has one armature

What am I doing wrong? Thanks for your help.

(Also, english isn't my first language, sorry if I made some mistakes)

more ▼

asked Apr 16, 2012 at 06:24 PM

Beldarak gravatar image

Beldarak
0 3 2 2

(comments are locked)
10|3000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Topics:

x75
x69

asked: Apr 16, 2012 at 06:24 PM

Seen: 1004 times

Last Updated: Apr 16, 2012 at 06:24 PM