Before updating to Windows 10 you may need to return your Pro license. More information here

[Closed] Android Splash Screen starting in Portrait mode

On searching around I've seen similar (though not quite the same) questions posed but haven't found a suitable answer.

We are developing for both iOS and Android. In the player settings we have the Default Orientation set to Auto Rotation and we have both Landscape option checked and both Portrait options unchecked. This all works great on iOS, if holding the device in portrait the game still starts in landscape.

On Android it causes the issue that the splash screen starts in portrait before attempting to switch to landscape after a couple of seconds. This isn't really acceptable to us, is there anyway to stop the splash screen from starting in portrait but still keeping the Default Orientation setting to Auto Rotation*


The reason we want to keep this setting is that it creates a nicer animated transition effect on iOS and it's a shared setting.

more ▼

asked Apr 04, 2012 at 01:27 PM

avatar image

429 39 30 36

@hazeti: Do you still have the bugreport id? It would be great if you could post it here as a comment, thanks.

Nov 27, 2012 at 12:20 PM Bunny83

Hey, the bug number is 456038. It's still marked as open though I haven't tested it recently. When I did submit the bug I did notice that it also happened on the AngryBots demo.

Nov 28, 2012 at 09:13 AM HazeTI

I have found this bug in my project and solved it successfully. There is no bug from unity side.

I have checked my android manifest file and in that one of the manifest file contains wrong orientation. I have change it to correct one and everything works fine.

Oct 17, 2014 at 11:35 AM siddharth3322
(comments are locked)
10|3000 characters needed characters left

The question has been closed May 16, 2012 at 01:44 PM by HazeTI for the following reason:

Problem is a bug within Unity and has been reported as such.

1 answer: sort oldest

Well, this post suggests just rotating the splash screen image, if you have a custom one, 90 degrees.

more ▼

answered Apr 05, 2012 at 01:40 AM

avatar image

CC Inc
241 35 32 39

Yeah, thanks for the suggestion. I read that answer, but all the does is rotate the image, the application is still running in Portrait mode. :/

Apr 05, 2012 at 08:30 AM HazeTI

Make sure your splash screen image is set to type GUI and not Texture.

Apr 05, 2012 at 12:00 PM CC Inc

It is. I don't really understand how rotating the splash image in a painting program will help. That will surely lead to the problem that it will still be the wrong way round if the phone is in landscape mode?

It still doesn't fix the fundamental problem that the app is starting in portrait mode when we're specifically telling it not to. I suspect it's a problem with Unity that we have no control over.

Apr 05, 2012 at 02:46 PM HazeTI

The point here, @Haze, is that if it is a problem with Unity then there's nothing we can do until they fix it. Report it and cross your fingers! http://unity3d.com/company/contact.html

Apr 05, 2012 at 02:49 PM Cawas

Thanks Cawas, I already sent them a bug report, but it's only a suspicion that the fault is on their end. I was asking the question in the hope that it wasn't and someone knew a setting to fix it. But I guess it really is on their end. Thanks :)

Apr 05, 2012 at 02:58 PM HazeTI
(comments are locked)
10|3000 characters needed characters left

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments



asked: Apr 04, 2012 at 01:27 PM

Seen: 4711 times

Last Updated: Oct 17, 2014 at 11:35 AM