x


type == m_TransformInfo.transformType

Hello,

We've just upgraded to Unity 3.5 and now we're seeing the following error occurring when some character animations are playing (the animations themselves play successfully):

type == m_TransformInfo.transformType UnityEditor.DockArea:OnGUI()

The interesting part is that it only occurs for a handful of the animations that we're using, even though they were all produced using the same pipeline. Sometimes it happens once or twice for an animation, and then not at all when run the next time. Sometimes it happens on every update for a specific animation. Plus, as I mentioned, we didn't have this error at all in Unity 3.4.

I read here: http://forum.unity3d.com/threads/123780-Unity-3.5-asset-type-m_TransformInfo.transformType about the possibility that flipping back and forth using scale = -1 may cause some errors, so we eliminated that but it did not fix the issue.

What is this error?

more ▼

asked Mar 13, 2012 at 03:44 PM

hrm100 gravatar image

hrm100
1 3 2 2

I have the same problem here. Its seems random.

Jun 09, 2012 at 11:35 PM Silicon Jelly

This seems to be an editor-only assertion. Nevertheless, it could prove to be annoying if you wanted to trap other errors (and subsequently pause the game when one occurs). Have you found a way to get rid of this message? I myself would like to know :D

Feb 01, 2013 at 05:31 AM zannghast

@jaroslavstehlik: this is not an answer to the question, so please don't post it as answer.

I've converted your answer into a comment.

Jun 09, 2012 at 11:36 PM Bunny83
(comments are locked)
10|3000 characters needed characters left

2 answers: sort voted first

This assertion seems to be happening when an object with an Animation component has unusual scale settings (e.g., 0) for at least one axis (either itself or one of its parents).

As it doesn't seem to break the functionality of the Animation, it may be ignored - but then it will keep spamming your console/error log, which might cause performance issues.

Instead, you might want to make sure that the scale is never 0 on any axis (you could set it to 0.00001 or something), or that you also disable the object if you are scaling it to 0.

more ▼

answered Feb 09, 2013 at 09:12 PM

Wolfram gravatar image

Wolfram
10.9k 23 50 84

Hi Wolfram, I'm eager to try your suggestion. Have any others worked on this?

Feb 11, 2013 at 08:44 AM zannghast

I Have tried this solution but to no avail. I'm having the problem on a model with animations which I'm scaling over time from 1 to -1. There are two moments on which I get the error.

1: When the coroutine goes from 0 to -1 (or even clamped from -0.3 to -1) 2: If I play any animation while the model is scaled to -1 (or scaled to anything below 0).

The animations are all playing without a problem though.. but the performance drops drastically in editor (not in build).

Feb 25, 2013 at 04:45 PM Teru
(comments are locked)
10|3000 characters needed characters left

We have solved same problem by reseting rotation of instanced particle system. Error happened to us, if parent object where PS is instancing have any negative scale.

more ▼

answered Dec 11, 2013 at 04:41 PM

AmegamiBy gravatar image

AmegamiBy
1

(comments are locked)
10|3000 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Topics:

x6963
x42
x8

asked: Mar 13, 2012 at 03:44 PM

Seen: 2564 times

Last Updated: Dec 11, 2013 at 04:41 PM