x


terrain not showing

The terrain isn't showing in both the scene view and the game view, but when I build and run the game the terrain shows up. Thanks in advance for answering a complete newb (to unity) ^^

more ▼

asked Jul 04, 2010 at 06:02 PM

Emil gravatar image

Emil
1 3 2 2

screen shots?

Jul 04, 2010 at 06:04 PM spinaljack
(comments are locked)
10|3000 characters needed characters left

3 answers: sort voted first

For terrain not showing up in Scene View two things come to mind. The first, you may have accidentally unchecked your terrain in the Inspector window - it would be grayed out in the Hierarchy window if so. The second, you may have just moved the view far away from it. In the Hierarchy window click on your terrain, then mouse over to Scene window (without clicking) and hit the F key (also Edit-> Frame Selected) to focus on it.

For Game view, you must make sure you have a camera set up, that it is enabled (again, not unchecked in the Inspector) and looking at part of the terrain. Lastly with the camera selected, in the Inspector under the Camera component look at the Near and Far clip planes, by default they are 0.3 and 1000, respectively. You can right-click the line that says Camera and hit Reset to bring these back to default.

Hope this helps..

more ▼

answered Jul 04, 2010 at 08:17 PM

TheDemiurge gravatar image

TheDemiurge
601 4 5 19

nope that's not it, thx for trying though

Jul 05, 2010 at 09:53 AM Emil
(comments are locked)
10|3000 characters needed characters left

A little late but I'll write it for posterity, you may have unchecked the 'default' layer in the 'Layers' dropdown box.

more ▼

answered Feb 11, 2011 at 11:55 PM

AnotherNoob gravatar image

AnotherNoob
17

That did it for me thanks alot! :)

Dec 29, 2011 at 07:13 PM madsleejensen

This worked for me too!

Feb 24, 2012 at 05:22 AM SpaceTacos
(comments are locked)
10|3000 characters needed characters left

Jumping in with a note here: I had this same problem with the terrain not showing, only I had all the layers activated. After trying a lot of things I went to Window -> Layouts -> Revert to factory settings, and that did the trick! Now the terrain is showing as it should.

more ▼

answered Oct 18, 2011 at 07:18 AM

Danevang gravatar image

Danevang
1

Or, I guess, three notes. Could you please delete your duplicate posts?

Oct 18, 2011 at 07:19 AM syclamoth
(comments are locked)
10|3000 characters needed characters left

Jumping in with a note here: I had this same problem with the terrain not showing, only I had all the layers activated. After trying a lot of things I went to Window -> Layouts -> Revert to factory settings, and that did the trick! Now the terrain is showing as it should.

more ▼

answered Oct 18, 2011 at 07:18 AM

Danevang gravatar image

Danevang
1

(comments are locked)
10|3000 characters needed characters left

Jumping in with a note here: I had this same problem with the terrain not showing, only I had all the layers activated. After trying a lot of things I went to Window -> Layouts -> Revert to factory settings, and that did the trick! Now the terrain is showing as it should.

more ▼

answered Oct 18, 2011 at 07:18 AM

Danevang gravatar image

Danevang
1

(comments are locked)
10|3000 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Topics:

x2641
x2348
x1156
x1150

asked: Jul 04, 2010 at 06:02 PM

Seen: 5271 times

Last Updated: Apr 27, 2013 at 11:02 AM