x


Unity Remote for Android not working (solution)

I have seen a lot of requests for people looking for help getting the Android Remote working.

I have been at it for a few hours to get it working on my new tablet. So here is a guide to getting it working.

Follow these steps and you should have no problems on any device (famous last words).

Step 1 - Download Android SDK

Step 2 - In the SDK installer ensure you install "Google USB Drivers"

Step 3 - Go to device manager and make sure your device has its drivers installed. You can get more help here. http://developer.android.com/sdk/win-usb.html

Step 4 - In Unity under preferences set the path to the Android SDK. C:\Program Files (x86)\Android\android-sdk or something similar.

Step 5 - Close Unity

Step 6 - On your android device ensure that in Application Settings that USB Debugging, Stay Awake and Allow Mock Locations are all enabled.

Step 7 - Connect via USB and launch the remote app.

Step 8 - Launch Unity

Step 9 - Run your game in the editor

Step 10 - Enjoy

Each time you restart the Unity Remote app you must restart Unity or the app will not pick it up. If I am in for a long dev session I plug in device and run remote and then begin work. Means I dont have to keep restarting Unity.

I hope this helps everyone who has a problem with Unity Remote on Android.

more ▼

asked Dec 26, 2011 at 08:43 AM

mabit gravatar image

mabit
341 58 46 48

thanks i have bean looking for a way to use the remote

May 16, 2012 at 10:30 PM qwertyqaz

First I found that "Unity Remote" is actually an app on the Google Play Store. But still no luck. I believe my drivers and firewall are all fine but no way to test. Is it working with the without Unity Android license?

May 24, 2012 at 11:22 PM Wernight

It seemed that the drivers where not correctly installed even though the Google Drivers were marked as working. It would be nice to have every version of Unity being able to check if the phone USB is correctly setup. Something like a red/green light or whatever.

After that, I didn't have to restart Unity which is really good and the Android displays the game screen.

May 25, 2012 at 11:24 PM Wernight

It's not always the best idea to install google's USB drivers. for some phones only the manufacturer's drivers will enable the use of USB debugging. If you want it to work for your phone, just search for "setting up ADB on DEVICENAME" and you will probably find what you need to do. If ADB see's your device, it should work in Unity.

a simple check is to run "adb.exe" that comes in platform-tools in the sdk from command line as "adb devices" if you see something listed, then you are good to go (in theory).

Adb working? check. Launch unity remote, check. Launch Unity and play your game.

Jul 18, 2012 at 12:26 AM WACOMalt

Would it work on Touch screen Monitors? Monitors?

Oct 31, 2013 at 09:22 AM sheheryar_noor

Thanks for this.

Sep 06, 2013 at 11:58 AM Setmaster
show all comments (comments are locked)
10|3000 characters needed characters left

3 answers: sort voted first
more ▼

answered Oct 04, 2012 at 04:23 PM

Stardog gravatar image

Stardog
356 81 70 105

Thanks, this solved my problem, I am using PTP as it was recommended there.

May 04, 2013 at 10:59 PM YIAOQ1

thanks this helps a lot

Jun 05, 2013 at 06:33 PM Justice

Thanks, the info is still valid. I needed to turn on the debug mode on my Samsung Galaxy S4 for the new Unity Remote 4 as well.

May 29 at 11:17 AM Simon Says
(comments are locked)
10|3000 characters needed characters left

I have a Samsung Galaxy Tab 3 7.0 and the device drivers from Google were my problem. I downloaded the Samsung Andorid USB Driver for Windows from here: http://developer.samsung.com/android/tools-sdks/Samsung-Andorid-USB-Driver-for-Windows and it worked straight away.

Anyway this driver will only work for Samsung devices but if you're having the same problems with your own device and Unity Remote, go to your Device Manager on Windows and make sure in the other devices branch (when your device is connected) there are no yellow "!" indicating problems with the drivers you currently have installed, if so then try find your device manufacturers official drivers and hopefully this will solve your problem.

more ▼

answered May 20 at 12:11 PM

BarryFoye gravatar image

BarryFoye
1

(comments are locked)
10|3000 characters needed characters left

Step 1 - Download Android SDK

Step 2 - In the SDK installer ensure you install "Google USB Drivers"

Step 3 - Go to device manager and make sure your device has its drivers installed. You can get more help here. http://developer.android.com/sdk/win-usb.html

Step 4 - In Unity under preferences set the path to the Android SDK. C:\Program Files (x86)\Android\android-sdk or something similar.

Step 4.1- Download the Remote app according to your platform, http://docs.unity3d.com/Manual/UnityRemote4.html

Step 4.2- In editor go to Edit->Project Settings->Editor and under Unity Remote select what device to use.

Step 5 - Close Unity

Step 6 - On your android device ensure that in Application Settings that USB Debugging, Stay Awake and Allow Mock Locations are all enabled.

Step 7 - Connect via USB and launch the remote app.

Step 8 - Launch Unity

Step 9 - Run your game in the editor

Step 10 - Enjoy

i added two more steps to the original and everything worked fine :)

more ▼

answered Jun 19 at 09:32 AM

shemz gravatar image

shemz
0

(comments are locked)
10|3000 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Topics:

x6608
x4688
x118
x103
x81

asked: Dec 26, 2011 at 08:43 AM

Seen: 51223 times

Last Updated: Jun 19 at 09:32 AM