x


Rocks moving

I have painted some rocks on my terrain as a detail mesh with render mode set to 'vertex lit'. For some strange reason the rocks move as if by the wind. If I change the alpha value of healthy color and the dry color to zero the affect reduces but they still move. Setting it to render mode 'grass' and alpha again to zero stops them swaying but of course this effects the color. Any idea how I can get 'vertex lit' working without the movement?

more ▼

asked Oct 26, 2011 at 01:57 AM

Robon gravatar image

Robon
238 25 922 37

Does the terrain engine assume that all detail meshes are supposed to be grass? I've never experienced this one!

Oct 26, 2011 at 02:47 AM syclamoth

I get the behavior in some of my projects but not other even when importing the same scene into all projects. I think there is some other project setting effecting it seeing as the scenes are identical.

Oct 26, 2011 at 03:15 AM Robon

It happens to me the same. :-( . I don't know why. I've got to experiment a bit more with it.

Oct 26, 2011 at 07:50 AM jorgon

Did anyone ever get a fix for this?

Nov 07, 2011 at 03:50 AM Robon

post comments only as COMMENTS please, thanks

May 03, 2013 at 10:20 AM Fattie
show all comments (comments are locked)
10|3000 characters needed characters left

1 answer: sort voted first

I had this issue on my unity, and it turned out that when I downloaded a pack of things for my scene, unbeknownst to me, a custom shader came with it. Even though I never used this shader in my scene, just it's presence in my asset folder caused a ton of my meshes to misbehave, including the rocks moving as if by wind even on vertexlit. The simple solution after months of angst: remove the shader from the project. As soon as I did that, all my meshes behaved properly again. In my case it happened to come wit the V2 package that allows you to use normal maps on your terrain in unity. Turns out that pack also comes with a ton of other shaders. Got rid of the ones I wasnt using, and everything works again. So yeah, for this problem, I HIGHLY recommend going through the things you have imported, and making sure no custom shaders snuck their way in.

more ▼

answered Jun 07 at 01:20 AM

AurorasMercy gravatar image

AurorasMercy
16

(comments are locked)
10|3000 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Topics:

x33
x14
x9

asked: Oct 26, 2011 at 01:57 AM

Seen: 1251 times

Last Updated: Jun 07 at 01:20 AM