x


Compiler Errors

I was just trying to create terrain in unity and i imported an asset

I tried to press play but then "All compiler errors have to be fixed before you can enter playmode!" came up

There are 2 errors in the console now they read:

Could not start compilationWin32Exception: ApplicationName='"C:/Users/family/Jarrod's Stuff/Editor/Data/Monobinmono.exe"', CommandLine='"C:/Users/family/Jarrod's Stuff/Editor/Data/Monolib/mono/unitysmcs.exe" @Temp/UnityTempFile-8fa0934a97958254da05a6137aa8388c', CurrentDirectory='C:/Users/family/Documents/New Unity Project/Assets/..' System.Diagnostics.Process.Start_noshell (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) System.Diagnostics.Process.Start_common (System.Diagnostics.ProcessStartInfo startInfo, System.Diagnostics.Process process) System.Diagnostics.Process.Start () (wrapper remoting-invoke-with-check) System.Diagnostics.Process:Start () UnityEditor.Utils.Program.Start () (at C:/BuildAgent/work/842f9557127e852/Editor/Mono/Utils/Program.cs:30) UnityEditor.Scripting.Compilers.ScriptCompilerBase.StartCompiler (BuildTarget target, System.String compiler, System.Collections.Generic.List`1 arguments) (at C:/BuildAgent/work/842f9557127e852/Editor/Mono/Scripting/Compilers/ScriptCompilerBase.cs:71) UnityEditor.Scripting.Compilers.CSharpCompiler.StartCompiler () (at C:/BuildAgent/work/842f9557127e852/Editor/Mono/Scripting/Compilers/CSharpCompiler.cs:31) UnityEditor.Scripting.Compilers.ScriptCompilerBase.BeginCompiling () (at C:/BuildAgent/work/842f9557127e852/Editor/Mono/Scripting/Compilers/ScriptCompilerBase.cs:39)

And also:

Compilation failed because the compiler couldn't be executed!

Please help because I have to use Unity for a massive project and I can't fix this.

more ▼

asked Sep 24 '11 at 02:39 AM

Jarrod_Walker gravatar image

Jarrod_Walker
16 5 5 7

Is this problem new and have you been working on a project for some time or is this early in the development of your project?

What was the asset you were trying to import? Is it a standard asset of a custom made one?

From what I can gather from the error message, it sounds like Unity was looking for a file named

unitysmcs.exe

at file location

  C:/Users/family/Jarrod's Stuff/Editor/Data/Monolib/mono/

but the file it was looking for either failed to open or does not exist.

Another file that might not be working:

C:/Users/family/Jarrod's Stuff/Editor/Data/Monobinmono.exe

Is there a file named unitysmcs.exe on your computer in the specified location? Does the file Monobinmono.exe exist in the other location?

Try removing the asset you imported right before the problem started. Does that change anything?

Sep 24 '11 at 02:53 AM SilverTabby

I tried removing the asset and the error "Compilation failed because the compiler couldn't be executed!" has disapeared but the other one is still there. I have searched for the file and it is non-existant. Any other suggestions would be helpful. Thank you.

Sep 24 '11 at 05:37 AM Jarrod_Walker

Turns out what I said didn't work. I've found out what the problem is because it keeps coming back, but i don't know how to fix it

The problem is that any time i try to import a character controller ,or something like that, the error comes back.

I have no idea how to fix this so please help or my project is doomed!!

Sep 28 '11 at 03:07 AM Jarrod_Walker

A third thing you can try is create a brand new, blank project, then copy your assets folder over to the new project, then see if that changes anything. The assets are what make the project, so copying only the assets should create a second project that is identical to the first.

If that doesn't help, then it sounds like something a clean install will fix. You project should be safe - it is a completely separate folder from the Unity install.

Another thing you can try, if you don't want to reinstall on your current computer, is to find/create a second computer with Unity on it. Copy over your entire project folder, and see if opening it there changes anything.

Sep 28 '11 at 03:26 AM SilverTabby

I have tried uninstalling and reinstalling Unity and this did not work.

I have also tried making a new project, but before the assets are copied the error is already there.

I cannot do the final thing you suggested because i do not have another computer on the same format as the one I am on.

Sep 28 '11 at 10:04 AM Jarrod_Walker
(comments are locked)
10|3000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Topics:

x2967
x146
x48

asked: Sep 24 '11 at 02:39 AM

Seen: 1857 times

Last Updated: Oct 14 '11 at 05:31 AM