x


Problem with MonoDevelop

Hello people.

This is my problem. I was working fine with Monodevelop until today. when I was going to compile a code the follwing error message came: The Compiler appears to have crashed. Check the build output pad for details. on the output pad here`s what it says: Water3.cs(329,54): error CS0241: Can`t allow specific default parameters.

and somtimes it says something with not having gtk2# or something like that..

since then I can`t use Monodevelop. With Uniscite everything works fine, but With Monodevelop, nothing compiles, even new projects.

Thank you for your help

more ▼

asked Jul 30, 2011 at 02:41 PM

George 10 gravatar image

George 10
4 15 10 14

(comments are locked)
10|3000 characters needed characters left

4 answers: sort oldest

I had a similar issue with MonoDevelop before, though it was slightly different- I got some random error that didn't make sense in the context of my code, then it crashed. When I tried to rerun it, nothing worked correctly.

Ultimately how I fixed it was to reboot my computer. Not sure if MonoDevelop has some sort of service or process that runs in the background or whatever, but after the reboot everything worked fine for me (and I was getting ready to reinstall it, so that saved me some headaches).

more ▼

answered Jul 30, 2011 at 04:49 PM

testure gravatar image

testure
4.6k 60 53 93

(comments are locked)
10|3000 characters needed characters left

I solved it, sorry I changed users, had a problem with the other.

to solve the problem I had to reimport all default assets and then monodevelop started compiling normally.

more ▼

answered Jul 30, 2011 at 04:53 PM

Georgeiv gravatar image

Georgeiv
1 2 2

(comments are locked)
10|3000 characters needed characters left

Addition on case if you got error CS0241 in Monodevelop only, but in Unity all is OK. Probably MonoDevelop work with .NET runtime which don't support C# 4.0 by default. (See in MonoDevelop's main menu ToolsOptionsPreferences.NET Runtimes)

You need to install latest version of Mono. Since Mono 2.8 the support of C# 4.0 is enabled. In MonoDevelop new runtime item must to appear automatically - set this by default and errors will disappear.

more ▼

answered Aug 01, 2012 at 03:39 PM

jite gravatar image

jite
95 3

(comments are locked)
10|3000 characters needed characters left

Also make sure to set the target framework correctly by right clicking Assembly-C Sharp-Editor in the Solution View and then choosing options. You'll find it in the popup menu under Build -> General. It was set to 3.5 for me somehow and caused the error.

more ▼

answered May 15, 2013 at 10:07 AM

vendetta1987 gravatar image

vendetta1987
1

(comments are locked)
10|3000 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Topics:

x4920

asked: Jul 30, 2011 at 02:41 PM

Seen: 2752 times

Last Updated: May 15, 2013 at 10:07 AM